Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0,,…’.

问题记录:

1,2019/6/19 17:06分:在服务器上用VS2008运行项目,提示版本不支持

2,2019/6/19 17:10分:安装.net 3.5功能。(IIS上应用池使用的是.net 2.0)

3,2019/6/19 18:58分:系统用户反映问题

4,系统日志

5,取消2步中的.net 3.5功能,再次访问正常。

6,百度搜索其他解决方案:–未测试

只要执行下面的操作,重新注册一下 asp.net 4.0:
C:/Windows/Microsoft.NET/Framework/v4.0.30319/aspnet_regiis.exe -iru

发表评论